Skip to main content
Main content

Last Updated on: 2017/10/04 01:00:00

Printer Driver Packager NX

Printer Driver Packager NX is a tool for IT managers to customize and package printer drivers.
Customizing allows them to control employees' printer driver settings.
Packaging allows IT managers to preset all the mandatory parameters for the printer driver installation.
Also multiple printer drivers can be gathered into one package so they can be installed by end users as a single execution.

Description Version Supported OS / Language Download / Size
Update Patch 01.01.12 Microsoft Windows Server 2016 (x64), Server 2012 R2(x64), Server 2012 (x64), Server 2008 R2(x64), Server 2008 (x64), Server 2008, 10(x64)*1*2, 10*1*2, 8.1(x64), 8.1, 7(x64), 7, Vista
*1 "LTSB" edition is not supported.
*2 Our supporting of Printer Driver Packager NX falls in line with Microsoft's supporting of Windows.
We only offer support for 1607 to 1703 regarding Windows10.
New version upgrades will be supported in order.

English, French, German, Spanish, Italian, Dutch, Simplified Chinese, Brazilian Portuguese
327 MB

✔: Available
N/A: Not Available

Applicable
Drivers
Driver Name
Version
Create
Package
Print configuration :
Customizable
Print configuration :
Import external file(.RCF)
Print configuration :
One Click Presets Customize
Print configuration :
Setting with the individual configuration file for UserCode / UserID / User Name
Model-Specific
Printer Drivers
PostScript
Ver1.1.0 or later / Ver1.0.0.0 or later

Ver1.0.0.0 or later
✔*1 N/A
PCL 5
Ver1.0.0.0 or later
N/A N/A N/A N/A
PCL 6
Ver1.0.0.0 or later
✔*1
LAN FAX
Ver1.50 or later / Ver2.0.0.0 or later
N/A
Ver2.0.0.0 or later
N/A N/A
RPCS-R
Ver1.0.0.0 or later
N/A
Universal
Printer Drivers
PostScript UD
Ver3.20.00 / Ver3.3.0.0 or later

Ver4.0.0.0 or later
✔*1
Ver4.6.0.0 or later
N/A
PS UD V4 *3
Ver1.0.0.0 or later
PCL 6 UD
Ver3.2.0.0 or later
✔*1
Ver4.6.0.0 or later
PCL 6 UD V4
Ver1.0.0.0 or later
OEM driver DDST (GDI)
Ver1.00 or later
✔*2 N/A N/A N/A N/A
PCL 6
Ver1.00 or later
LAN FAX
Ver1.01 or later

*1 The following Model-Specific Printer drivers and PCL6/PS Driver for Universal Print Ver.4.6.0.0 or later.
RICOH MP 305+ / 402 / 501 / 601 / 6503 / 7503 / 9003
RICOH MP C306 / C406 / C2004 / C2094 / C2054 / C2504 / C3004 / C3504 / C4504 / C5504 / C6004 / CW2201
RICOH MP W7100 / W8140 / W6700
RICOH SP 5300 / 5310
RICOH SP C340 / C342 / C352 / C435 / C440 / C840 / C842
RICOH Pro 8100 / 8110 / 8120 / 8200 / 8210 / 8220
RICOH Pro C7100 / C7110
2017 or later release date
*2 RICOH MP 2014
RICOH SP C250 / C252 /310 / 311 / 312
RICOH Aficio SP C240 / C242 / 3500 / 3510
*3 .NET Framework 4.5.2 or higher is required for PCL6/PS V4 Driver for Universal Print packagecreation.

Page Top